INC-1644 - Intermittent login issues

Incident Report for BILL System Status

Resolved

Start Time: March 09, 2026 10:54 AM Pacific Time Zone
End Time: March 09, 2026 12:55 PM Pacific Time Zone
Description: We are currently experiencing issues with users logging into our site.

Status: We have seen no further occurrences of the issue. We are now closing this matter.
Posted Mar 09, 2026 - 13:42 PDT

Monitoring

Start Time: March 09, 2026 10:54 AM Pacific Time Zone
End Time: March 09, 2026 12:55 PM Pacific Time Zone
Description: We are currently experiencing issues with users logging into our site.

Status: The issue has been addressed. We are now monitoring the service.
Posted Mar 09, 2026 - 12:58 PDT

Identified

Start Time: March 09, 2026 10:54 AM Pacific Time Zone
End Time: N/A
Description: We are currently experiencing issues with users logging into our site.

Status: We have identified the issue and are working to quickly resolve the issue.
Posted Mar 09, 2026 - 12:02 PDT
This incident affected: BILL Platform.