TECHOPS-59568 - BILL front page can fail to load
Incident Report for BILL System Status
Resolved
Start Time: December 9, 2022 11:51 AM Pacific Time Zone
End Time: December 9, 2022 12:31 PM Pacific Time Zone
Description: BILL landing page fails to load

Status: We have seen no further occurrences of the issue. We are now closing this matter.
Posted Dec 09, 2022 - 18:59 PST
Monitoring
Start Time: December 9, 2022 11:51 AM Pacific Time Zone
End Time: December 9, 2022 12:31 PM Pacific Time Zone
Description: BILL landing page fails to load

Status: Functionality has been restored. We are now monitoring the service.
Posted Dec 09, 2022 - 12:57 PST
Identified
Start Time: December 9, 2022 11:51 AM Pacific Time Zone
End Time: N/A
Description: BILL landing page fails to load

Status: The issue has been identified. We are working on a resolution. As a workaround users can login via https://login.us.bill.com
Posted Dec 09, 2022 - 12:21 PST
This incident affected: BILL Platform.