Site is Unavailable
Incident Report for Bill.com System Status
Resolved
Start Time: Feb 24, 2021 10:23 PM Pacific Time Zone
End Time: Feb 25, 2021 01:04 AM Pacific Time Zone
Description: The site is currently unavailable.

Status: We have resolved the issue and implemented the solution. Thank you for your patience.
Posted Feb 25, 2021 - 02:06 PST
Identified
Start Time: Feb 24, 2021 10:23 PM Pacific Time Zone
Description: The site is currently unavailable.

Status: The cause of the issue has been identified and we are actively working on a resolution.
Posted Feb 25, 2021 - 01:30 PST
Investigating
Start Time: Feb 24, 2021 10:23 PM Pacific Time Zone
Description: The site is currently unavailable.

Status: We are aware of a service disruption. Our teams are working to identify the cause and implement a solution.
Posted Feb 24, 2021 - 22:51 PST
This incident affected: Sync Integrations (QuickBooks for Windows, QuickBooks Online, Intuit Bill Pay, Intacct, NetSuite, Xero) and Bill.com Platform, Mobile, Domestic Payments, International Payments, Vendor Direct, API Servers, Multi-Factor Authentication, Support Center.