SRE-3971 - Main Bill.com Landing Page Not Loading
Incident Report for Bill.com System Status
Resolved
Start Time: Mar 2, 2022 6:00 AM Pacific Time Zone
End Time: Mar 2, 2022 7:10 AM Pacific Time Zone
Description: Main Bill.com landing page is not loading. Users can bypass the failing page by navigating to login.us.bill.com to directly access the login page.

Status: We have resolved the issue and implemented the solution. Thank you for your patience.
Posted Mar 02, 2022 - 14:31 PST
Monitoring
Start Time: Mar 2, 2022 6:00 AM Pacific Time Zone
End Time: Mar 2, 2022 7:10 AM Pacific Time Zone
Description: Main Bill.com landing page is not loading. Users can bypass the failing page by navigating to login.us.bill.com to directly access the login page.

Status: We have restored access to the main Bill.com landing page. We are monitoring the situation for further occurrences.
Posted Mar 02, 2022 - 07:13 PST
Investigating
Start Time: Mar 2, 2022 6:00 AM Pacific Time Zone
End Time: N/A
Description: Main Bill.com landing page is not loading. Users can bypass the failing page by navigating to login.us.bill.com to directly access the login page.

Status: We are investigating the cause of this issue.
Posted Mar 02, 2022 - 06:46 PST
This incident affected: Bill.com Platform.