INC-719 - Users seeing blank screen on login
Incident Report for BILL System Status
Resolved
Start Time: May 20, 2024 06:18 AM Pacific Time Zone
End Time: May 20, 2024 07:13 AM Pacific Time Zone
Description: Users attempting to access the application may see a blank screen

Status: We have seen no further occurrences of the issue. We are now closing this matter.
Posted May 20, 2024 - 11:15 PDT
Monitoring
Start Time: May 20, 2024 06:18 AM Pacific Time Zone
End Time: May 20, 2024 07:13 AM Pacific Time Zone
Description: Users attempting to access the application may see a blank screen

Status: Issue has been addressed. Our team will continue to monitor the status.
Posted May 20, 2024 - 07:17 PDT
Investigating
Start Time: May 20, 2024 06:18 AM Pacific Time Zone
End Time: N/A
Description: Users attempting to access the application may see a blank screen

Status: The team is inquiring about users experiencing difficulty logging into our site.
Posted May 20, 2024 - 06:55 PDT
This incident affected: BILL Platform.